summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-10-20 18:32:12 +0000
committerKei Kebreau <kkebreau@posteo.net>2017-10-27 08:25:55 -0400
commite37bdc0f288cd23103c03b18abdaed89f6f51e49 (patch)
tree820d4e6943b5600c581277dfb429c79da807b7f1 /gnu
parentc50fe6c291f248ee3f5a7bd9cef7ba290529ebdd (diff)
downloadguix-e37bdc0f288cd23103c03b18abdaed89f6f51e49.tar.gz
gnu: Add gavl.
* gnu/packages/video.scm (gavl): New variable.

Signed-off-by: Kei Kebreau <kkebreau@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 4aa9c63a3c..ddd5672d5c 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -69,6 +69,7 @@
   #:use-module (gnu packages databases)
   #:use-module (gnu packages dejagnu)
   #:use-module (gnu packages docbook)
+  #:use-module (gnu packages documentation)
   #:use-module (gnu packages elf)
   #:use-module (gnu packages file)
   #:use-module (gnu packages flex)
@@ -2512,3 +2513,36 @@ tools for styling them, including a built-in real-time video preview.")
     (synopsis "GStreamer Transcoding API")
     (description "GStreamer Transcoding API")
     (license license:lgpl2.1)))
+
+(define-public gavl
+  (package
+    (name "gavl")
+    (version "1.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/gmerlin/"
+                           name "/" version "/"
+                           name "-" version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1kikkn971a14zzm7svi7190ldc14fjai0xyhpbcmp48s750sraji"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("doxygen" ,doxygen)))
+    (home-page "http://gmerlin.sourceforge.net")
+    (synopsis "Low level library for multimedia API building")
+    (description
+     "Gavl is short for Gmerlin Audio Video Library.  It is a low level
+library, upon which multimedia APIs can be built.  Gavl handles all the
+details of audio and video formats like colorspaces, sample rates,
+multichannel configurations, etc.  It provides standardized definitions for
+those formats as well as container structures for carrying audio samples or
+video images inside an application.
+
+In addition, it handles the sometimes ugly task of converting between all
+these formats and provides some elementary operations (copying, scaling,
+alpha blending etc).")
+    (license license:gpl3)))