summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:10:06 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:57 -0400
commite7e2f03c8f3cb8d5e376af6b67704849246aafa6 (patch)
tree9ef3b2c9f847474fb4063813d4da54212a807cc2 /gnu
parent3db882776b97f38f0563165c981fd5504d103b5c (diff)
downloadguix-e7e2f03c8f3cb8d5e376af6b67704849246aafa6.tar.gz
gnu: Add ghc-array.
* gnu/packages/haskell.scm (ghc-array): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index cdacc56a04..1586923134 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7044,4 +7044,27 @@ and edge labels with positional information, etc.
 @end enumerate\n")
     (license license:bsd-3)))
 
+(define-public ghc-array
+  (package
+    (name "ghc-array")
+    (version "0.5.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/array/array-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "08r2rq4blvc737mrg3xhlwiw13jmsz5dlf2fd0ghb9cdaxc6kjc9"))))
+    (build-system haskell-build-system)
+    (home-page
+     "http://hackage.haskell.org/package/array")
+    (synopsis "Mutable and immutable arrays")
+    (description
+     "In addition to providing the @code{Data.Array} module, this package also defines
+the classes @code{IArray} of immutable arrays and @code{MArray} of arrays mutable
+within appropriate monads, as well as some instances of these classes.")
+    (license license:bsd-3)))
+
 ;;; haskell.scm ends here