summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPjotr Prins <pjotr.public12@thebird.nl>2014-10-27 06:30:09 +0100
committerMark H Weaver <mhw@netris.org>2014-10-27 03:20:32 -0400
commit218ee89b0cf11483e7b3bf57e0bef340f5531206 (patch)
tree1da65d57003127cbb8dcb6eab66453f2118dd338 /gnu
parentb94ae0b89e00f3bfb51d0e5f087366e78e1d9742 (diff)
downloadguix-218ee89b0cf11483e7b3bf57e0bef340f5531206.tar.gz
gnu: Add ruby 1.8.7.
* gnu/packages/ruby.scm (ruby-1.8): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index ac751f58d5..5814089ff8 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -89,6 +89,34 @@ a focus on simplicity and productivity.")
     (home-page "https://ruby-lang.org")
     (license license:ruby)))
 
+(define-public ruby-1.8
+  (package (inherit ruby)
+    (name "ruby")
+    (version "1.8.7-p374")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://cache.ruby-lang.org/pub/ruby/1.8/"
+                           name "-" version ".tar.bz2"))
+       (sha256
+        (base32
+         "1qq7khilwkayrhwmzlxk83scrmiqfi7lgsn4c63znyvz2c1lgqxl"))))
+    (native-search-paths '())
+    (arguments
+     `(#:test-target "test"
+       #:parallel-tests? #f
+       #:phases
+        (alist-cons-before
+         'configure 'replace-bin-sh
+         (lambda _
+           (substitute* '("Makefile.in"
+                          "ext/pty/pty.c"
+                          "io.c"
+                          "lib/mkmf.rb"
+                          "process.c")
+             (("/bin/sh") (which "sh"))))
+         %standard-phases)))))
+
 (define-public ruby-i18n
   (package
     (name "ruby-i18n")