summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-07-24 14:16:25 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-16 17:04:10 +0200
commit0fccd15f7895e86982ee30097bb1349fff3accb4 (patch)
tree453b514f31ac25f544b7217f36e8c301078e60d0 /gnu
parente7448859cec690e73bc67c82e37465dc101eea25 (diff)
downloadguix-0fccd15f7895e86982ee30097bb1349fff3accb4.tar.gz
gnu: Add r-doby.
* gnu/packages/cran.scm (r-doby): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a78a97e015..78ca98d502 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4662,3 +4662,35 @@ Superiority (PS), and the Number needed to treat (NNT) effect size.  Moreover,
 comparisons to Cohen's d are offered based on Huberty & Lowman's Percentage of
 Group (Non-)Overlap considerations.")
     (license license:gpl2)))
+
+(define-public r-doby
+  (package
+    (name "r-doby")
+    (version "4.6-1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "doBy" version))
+       (sha256
+        (base32
+         "1y02awzid23bxz8hx6j8pxd6i7jaq8pdw3k60rag8y6m69incrw5"))))
+    (properties `((upstream-name . "doBy")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-dplyr" ,r-dplyr)
+       ("r-magrittr" ,r-magrittr)
+       ("r-mass" ,r-mass)
+       ("r-matrix" ,r-matrix)
+       ("r-plyr" ,r-plyr)))
+    (home-page "http://people.math.aau.dk/~sorenh/software/doBy/")
+    (synopsis "Groupwise statistics, LSmeans, linear contrasts, and utilities")
+    (description
+     "This package contains:
+
+@itemize
+@item facilities for working with grouped data: @code{do}
+  something to data stratified @code{by} some variables.
+@item implementations of least-squares means, general linear contrasts, and
+@item miscellaneous other utilities.
+@end itemize\n")
+    (license license:gpl2+)))