summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-08 14:18:26 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-10 18:37:59 +0200
commit23e12d9d4fbc810e58407cb38e86c8fd08e791a2 (patch)
tree9c8fcdd05fe53694f544ea779c8687c48467f1d9 /gnu
parent2e957aae25a0849732789da8b7efab74c4721a94 (diff)
downloadguix-23e12d9d4fbc810e58407cb38e86c8fd08e791a2.tar.gz
gnu: rofi: Update to 1.4.1.
* gnu/packages/check.scm (check-0.11.0): New variable.
* gnu/packages/xdisorg.scm (rofi): Update to 1.4.1.
[inputs]: Add LIBRSVG.
[native-inputs]: Add BISON, CHECK-0.11.0 and FLEX.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm15
-rw-r--r--gnu/packages/xdisorg.scm12
2 files changed, 24 insertions, 3 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 45ac7d786c..b2ce42b08c 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -10,6 +10,7 @@
 ;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2017 ng0 <ng0@infotropique.org>
 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -64,6 +65,20 @@ faults or other signals.  The output from unit tests can be used within
 source code editors and IDEs.")
     (license lgpl2.1+)))
 
+;; XXX: Some packages require this newer version.  Incorporate this
+;; into the main 'check' package during the next rebuild cycle.
+(define-public check-0.11.0
+  (package
+    (inherit check)
+    (version "0.11.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/libcheck/check/releases"
+                                  "/download/" version "/check-" version ".tar.gz"))
+              (sha256
+               (base32
+                "05jn1pgb7hqb937xky2147nnq3r4qy5wwr79rddpax3bms5a9xr4"))))))
+
 (define-public cunit
   (package
     (name "cunit")
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 7ca4986a0e..cf7dcf8f61 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -49,9 +49,11 @@
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages autotools)
+  #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages image)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages flex)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
@@ -1054,7 +1056,7 @@ connectivity of the X server running on a particular @code{DISPLAY}.")
 (define-public rofi
   (package
     (name "rofi")
-    (version "1.3.1")
+    (version "1.4.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/DaveDavenport/rofi/"
@@ -1062,20 +1064,24 @@ connectivity of the X server running on a particular @code{DISPLAY}.")
                                   version "/rofi-" version ".tar.xz"))
               (sha256
                (base32
-                "1s47biv6d68nblpz6d3aklsar1xxxcilzr4y77v3hz2w1wbz2b5m"))))
+                "0xnfzbwhxd2cd4lxkc24mbx3f4b1h3l1alcdbbsymi2b9fdwmywh"))))
     (build-system gnu-build-system)
     (inputs
      `(("pango" ,pango)
        ("cairo" ,cairo)
        ("glib" ,glib)
        ("startup-notification" ,startup-notification)
+       ("librsvg" ,librsvg)
        ("libxkbcommon" ,libxkbcommon)
        ("libxcb" ,libxcb)
        ("xcb-util" ,xcb-util)
        ("xcb-util-xrm" ,xcb-util-xrm)
        ("xcb-util-wm" ,xcb-util-wm)))
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
+     `(("bison" ,bison)
+       ("check" ,check-0.11.0)
+       ("flex" ,flex)
+       ("pkg-config" ,pkg-config)))
     (arguments
      `(#:parallel-tests? #f ; May fail in some circumstances.
        #:phases