summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:07:11 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:14 +0300
commit26165a796012d619feba1beb20fff5487e7e701a (patch)
treefe169e89eca5b8ba226b32b6b5751dd7d58cb406 /gnu
parentc25dda7e7dcae711285c1cb3951120ac946a3342 (diff)
downloadguix-26165a796012d619feba1beb20fff5487e7e701a.tar.gz
gnu: Add emacs-magit-org-todos-el.
* gnu/packages/emacs.scm (emacs-magit-org-todos-el): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 85fc7beb9d..609bc87faa 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -9441,3 +9441,29 @@ time is being spent during Emacs startup in order to optimize startup time.")
       (description "@code{emms-player-simple-mpv} provides macros and
 functions for defining emms simple players of mpv.")
       (license license:gpl3+))))
+
+(define-public emacs-magit-org-todos-el
+  (let ((commit "df206287737b9671f2e36ae7b1474ebbe9940d2a"))
+    (package
+      (name "emacs-magit-org-todos-el")
+      (version (git-version "0.1.1" "1" commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/danielma/magit-org-todos.el.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0kdp7k7jnnrkhsg0xh1c3h7iz0vgi120gf5xwl1hxy61avivnxrn"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/danielma/magit-org-todos.el")
+      (synopsis "Get todo.org into Emacs Magit status")
+      (description "This package allows you to get @file{todo.org} into your
+magit status.
+
+If you have a @file{todo.org} file with @code{TODO} items in the root of your
+repository, @code{magit-org-todos} will create a section in your Magit status
+buffer with each of your todos.")
+      (license license:gpl3+))))