summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-29 21:58:45 -0400
committerLeo Famulari <leo@famulari.name>2016-10-29 22:16:19 -0400
commit2ddbfa8c06fb3fdd1c4367d735c12ec1efd81fd2 (patch)
tree46c22976318e12887f69a7ca514be94b8b3cde11 /gnu
parent269d9172ff037bd41bee3777166b3bc14d93f745 (diff)
downloadguix-2ddbfa8c06fb3fdd1c4367d735c12ec1efd81fd2.tar.gz
gnu: python-pyquery: Add inputs for test suite.
* gnu/packages/python.scm (python-pyquery,
python2-pyquery)[native-inputs]: Add python-webob and python-webtest.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7cfbd997d8..1247e5ef70 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8309,6 +8309,9 @@ layouts.")
         (base32
          "0j9fsisip21qv4xljsg5dmni1pgpvwrjyyhhql0glydc4bs5rjgv"))))
     (build-system python-build-system)
+    (native-inputs
+     `(("python-webob" ,python-webob)
+       ("python-webtest" ,python-webtest)))
     (propagated-inputs
      `(("python-lxml" ,python-lxml)
        ("python-cssselect" ,python-cssselect)))
@@ -8325,7 +8328,8 @@ fast xml and html manipulation.")
                   (strip-python2-variant python-pyquery))))
     (package
       (inherit pyquery)
-      (native-inputs `(("python2-setuptools" ,python2-setuptools))))))
+      (native-inputs `(("python2-setuptools" ,python2-setuptools)
+                       ,@(package-native-inputs pyquery))))))
 
 (define-public python-webtest
   (package