summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-15 20:13:29 -0400
committerLeo Famulari <leo@famulari.name>2016-10-15 20:14:55 -0400
commit2f87a77ff7fcd83c2de6b513eb49819e17232d95 (patch)
tree830de963f1c95f4f1ad3cc3fd48ba2e89ca34d99 /gnu
parent4c8c2b0f54233ad75dbc1a161176c1f7233b5e03 (diff)
downloadguix-2f87a77ff7fcd83c2de6b513eb49819e17232d95.tar.gz
gnu: python2-file: Build with setuptools.
* gnu/packages/python.scm (python-file)[properties]: New field.
(python2-file): Use strip-python2-variant.
[native-inputs]: Add python2-setuptools.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 1b35bf0807..02ec731c40 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6465,10 +6465,16 @@ Python's @code{ctypes} foreign function interface (FFI).")
     (synopsis "Python bindings to the libmagic file type guesser.  Note that
 this module and the python-magic module both provide a \"magic.py\" file;
 these two modules, which are different and were developed separately, both
-serve the same purpose: provide Python bindings for libmagic.")))
+serve the same purpose: provide Python bindings for libmagic.")
+    (properties `((python2-variant . ,(delay python2-file))))))
 
 (define-public python2-file
-  (package-with-python2 python-file))
+  (let ((base (package-with-python2 (strip-python2-variant python-file))))
+    (package
+      (inherit base)
+      (native-inputs
+       `(("python2-setuptools" ,python2-setuptools)
+         ,@(package-native-inputs base))))))
 
 (define-public python-debian
   (package