summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Hashe <david.hashe@dhashe.com>2015-04-17 00:09:42 -0500
committerLudovic Courtès <ludo@gnu.org>2015-04-17 13:53:16 +0200
commit3c9e35cce748355a3955a3fdf15010c7868bfab8 (patch)
treeede42262c69f9055d22730229bbb62189a5e85a6 /gnu
parent007aa90b2116e73c2288f04ace37d4a6d0142d6c (diff)
downloadguix-3c9e35cce748355a3955a3fdf15010c7868bfab8.tar.gz
gnu: Add libsrtp.
* gnu/packages/telephony.scm (libsrtp): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/telephony.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index b9e38c33d0..4506690500 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -20,6 +21,7 @@
 (define-module (gnu packages telephony)
   #:use-module (gnu packages)
   #:use-module (gnu packages gnupg)
+  #:use-module (gnu packages linux)
   #:use-module (gnu packages pkg-config)
   #:use-module (guix licenses)
   #:use-module (guix packages)
@@ -183,3 +185,25 @@ internet.")
    (license gpl3+)
    (home-page "http://www.gnu.org/software/sipwitch")))
 
+(define-public libsrtp
+  (package
+    (name "libsrtp")
+    (version "1.5.2")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "https://github.com/cisco/libsrtp/archive/v"
+                                  version ".tar.gz"))
+             (sha256
+              (base32
+               "1njf62f6sazz2q7qc4j495v1pga385whkmxxyr8hfz1ragiyzqc6"))))
+    (native-inputs
+     `(("procps" ,procps)))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:test-target "runtest"))
+    (synopsis "Secure RTP (SRTP) Reference Implementation")
+    (description "This package provides an implementation of the Secure
+Real-time Transport Protocol (SRTP), the Universal Security Transform (UST),
+and a supporting cryptographic kernel.")
+    (home-page "https://github.com/cisco/libsrtp")
+    (license bsd-3)))