summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 04:10:00 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:44:33 -0400
commit4f2f53f939390011dda68d7d0d8467fe1cdc371d (patch)
treef4c6e346ddd4d717c8cb3504a6a8e4199a520658 /gnu
parentd8ac82c209a786c39de20102cd90810b4ddb0f44 (diff)
downloadguix-4f2f53f939390011dda68d7d0d8467fe1cdc371d.tar.gz
gnu: texlive-latex-base: Use invoke.
* gnu/packages/tex.scm (texlive-latex-base)[arguments]: Use invoke and remove
vestigial plumbing.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm60
1 files changed, 29 insertions, 31 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 36b7def056..50958cf199 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -949,37 +949,35 @@ book).")
 
                (mkdir "build")
                (mkdir "web2c")
-               (and (invoke "luatex" "-ini" "-interaction=batchmode"
-                            "-output-directory=build" "unpack.ins")
-                    (invoke "tex" "-ini" "-interaction=batchmode"
-                            "-output-directory=web2c" "tex.ini")
-                    ;; LaTeX, pdfetex/pdftex, and XeTeX require e-TeX, which
-                    ;; is enabled only in extended mode (activated with a
-                    ;; leading asterisk).  We should not use luatex here,
-                    ;; because that would make the generated format files
-                    ;; incompatible with any other TeX engine.
-                    (every
-                     (lambda (format)
-                       (invoke "latex" "-ini" "-interaction=batchmode"
-                               "-output-directory=web2c"
-                               "-translate-file=cp227.tcx"
-                               (string-append "*" format ".ini")))
-                     '("latex"
-                       "pdflatex"
-                       "pdfetex"))
-                    (every
-                     (lambda (format)
-                       (invoke format "-ini" "-interaction=batchmode"
-                               "-output-directory=web2c"
-                               (string-append "*" format ".ini")))
-                     '("xetex"
-                       "xelatex"))
-                    (every
-                     (lambda (format)
-                       (invoke "luatex" "-ini" "-interaction=batchmode"
-                               "-output-directory=web2c"
-                               (string-append format ".ini")))
-                     '("dviluatex" "dvilualatex" "luatex" "lualatex")))))
+               (invoke "luatex" "-ini" "-interaction=batchmode"
+                       "-output-directory=build" "unpack.ins")
+               (invoke "tex" "-ini" "-interaction=batchmode"
+                       "-output-directory=web2c" "tex.ini")
+               ;; LaTeX, pdfetex/pdftex, and XeTeX require e-TeX, which
+               ;; is enabled only in extended mode (activated with a
+               ;; leading asterisk).  We should not use luatex here,
+               ;; because that would make the generated format files
+               ;; incompatible with any other TeX engine.
+               (for-each (lambda (format)
+                           (invoke "latex" "-ini" "-interaction=batchmode"
+                                   "-output-directory=web2c"
+                                   "-translate-file=cp227.tcx"
+                                   (string-append "*" format ".ini")))
+                         '("latex"
+                           "pdflatex"
+                           "pdfetex"))
+               (for-each (lambda (format)
+                           (invoke format "-ini" "-interaction=batchmode"
+                                   "-output-directory=web2c"
+                                   (string-append "*" format ".ini")))
+                         '("xetex"
+                           "xelatex"))
+               (for-each (lambda (format)
+                           (invoke "luatex" "-ini" "-interaction=batchmode"
+                                   "-output-directory=web2c"
+                                   (string-append format ".ini")))
+                         '("dviluatex" "dvilualatex" "luatex" "lualatex"))
+               #t))
            (replace 'install
              (lambda* (#:key outputs #:allow-other-keys)
                (let* ((out (assoc-ref outputs "out"))