summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-28 19:22:13 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-10-30 21:34:15 +0100
commit5df4e27fec27d20ab2c17691b2c5ff15ce8fb066 (patch)
treeb8954d423ddfad2c48367b64e3af23a26ffef91e /gnu
parent7d8f34707a9fb41b88b5ea0a0cee7068ce9e9cf0 (diff)
downloadguix-5df4e27fec27d20ab2c17691b2c5ff15ce8fb066.tar.gz
gnu: Add r-rcmdcheck.
* gnu/packages/cran.scm (r-rcmdcheck): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9e4ea6b0a4..c6fab7554e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6879,3 +6879,34 @@ the code was copied over from @code{devtools}.")
      "This package provides a cross-platform solution to open files,
 directories or URLs with their associated programs.")
     (license license:expat)))
+
+(define-public r-rcmdcheck
+  (package
+    (name "r-rcmdcheck")
+    (version "1.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "rcmdcheck" version))
+       (sha256
+        (base32
+         "13liz9lmx9xgc0f7pjiz3sp8ygvazx2zslbiwz3p9fimfsx1yfsg"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-callr" ,r-callr)
+       ("r-cli" ,r-cli)
+       ("r-crayon" ,r-crayon)
+       ("r-desc" ,r-desc)
+       ("r-digest" ,r-digest)
+       ("r-pkgbuild" ,r-pkgbuild)
+       ("r-prettyunits" ,r-prettyunits)
+       ("r-r6" ,r-r6)
+       ("r-rprojroot" ,r-rprojroot)
+       ("r-withr" ,r-withr)
+       ("r-xopen" ,r-xopen)))
+    (home-page "https://github.com/r-Lib/rcmdcheck#readme")
+    (synopsis "Run R CMD check from R and capture results")
+    (description
+     "Run @code{R CMD check} from R programmatically, and capture the results
+of the individual checks.")
+    (license license:expat)))