summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-05-02 15:10:05 +0200
committerLudovic Courtès <ludo@gnu.org>2017-05-02 15:10:05 +0200
commit693f12ce2326f82020e90e58e69cf2b54808c19b (patch)
tree983c23a4865065592dc65bea5e2e4a37a2199ab4 /gnu
parent8a2105078b5845e31768da06b360676352b1f3e9 (diff)
downloadguix-693f12ce2326f82020e90e58e69cf2b54808c19b.tar.gz
build: 'check-system' now depends on the bootstrap Guile tarballs.
Reported by Chris Marusich <cmmarusich@gmail.com>.

* gnu/local.mk (BOOTSTRAP_GUILE_TARBALLS): New variable.
(DISTCLEANFILES): Define as an alias for 'BOOTSTRAP_GUILE_TARBALLS'.
* Makefile.am (check-system): Depend on $(BOOTSTRAP_GUILE_TARBALLS).
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 52000a2c53..28ab73aed3 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1087,13 +1087,15 @@ nodist_bootstrap_mips64el_linux_DATA =					\
 set-bootstrap-executable-permissions:
 	chmod +x $(DESTDIR)$(bootstrapdir)/*/{bash,mkdir,tar,xz}
 
-DISTCLEANFILES =				\
+BOOTSTRAP_GUILE_TARBALLS =			\
   $(nodist_bootstrap_x86_64_linux_DATA)		\
   $(nodist_bootstrap_i686_linux_DATA)		\
   $(nodist_bootstrap_armhf_linux_DATA)		\
-  $(nodist_bootstrap_aarch64_linux_DATA)		\
+  $(nodist_bootstrap_aarch64_linux_DATA)	\
   $(nodist_bootstrap_mips64el_linux_DATA)
 
+DISTCLEANFILES = $(BOOTSTRAP_GUILE_TARBALLS)
+
 # Method to download a file from an external source.
 DOWNLOAD_FILE =								\
   GUILE_LOAD_COMPILED_PATH="$(top_builddir):$$GUILE_LOAD_COMPILED_PATH"	\