summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-10-29 18:48:28 +0200
committerDavid Craven <david@craven.ch>2016-10-29 23:51:43 +0200
commit6ad3befef2f405c3b0866f43cd155175c29e5a3f (patch)
tree4f5099b72c2a2c9531e50929402fe7d40649d73b /gnu
parentbeb21382d30ced80b783060e4db8aadda18b1ef3 (diff)
downloadguix-6ad3befef2f405c3b0866f43cd155175c29e5a3f.tar.gz
gnu: solid: Update to 5.27.0.
* gnu/packages/kde-frameworks.scm (solid): Update to 5.27.0.
  [native-inputs]: Add flex-2.6.1.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm26
1 files changed, 16 insertions, 10 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index fcdf0341b1..6fa4215996 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -35,6 +35,7 @@
   #:use-module (gnu packages databases)
   #:use-module (gnu packages disk)
   #:use-module (gnu packages docbook)
+  #:use-module (gnu packages flex)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
@@ -1034,20 +1035,25 @@ which are used in DBus communication.")
 (define-public solid
   (package
     (name "solid")
-    (version "5.24.0")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (string-append "mirror://kde/stable/frameworks/"
-                            (version-major+minor version) "/"
-                            name "-" version ".tar.xz"))
-        (sha256
-         (base32
-          "00wvsxcnvhdx7ijzpcz5wny2ypkxr1drdpr4yvawgpwa678l1107"))))
+    (version "5.27.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://kde/stable/frameworks/"
+                    (version-major+minor version) "/"
+                    name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "01qlfj30n8sr8xd8l8fimg7hs7h70ynhalk2m9l8dz2qay2pdl27"))))
     (build-system cmake-build-system)
     (native-inputs
      `(("bison" ,bison)
        ("extra-cmake-modules" ,extra-cmake-modules)
+       ;; extra-cmake-modules forces C89 for all C files for compatibility with
+       ;; Windows.  Flex 2.6.0 generates a lexer containing a single line
+       ;; comment.  Single line comments are part of the C99 standard, so the
+       ;; lexer won't compile if C89 is used.
+       ("flex" ,flex-2.6.1)
        ("qttools" ,qttools)))
     (inputs
      `(("qtbase" ,qtbase)