summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-08-15 11:23:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-16 17:04:11 +0200
commit6c7a3279adcac004080dc0771e8bf6822d3a28a2 (patch)
tree740abce905fc0137880081eff8cf7617cf91f7f5 /gnu
parent7da274a808a40bc23d2d854a3e96070d31a56d95 (diff)
downloadguix-6c7a3279adcac004080dc0771e8bf6822d3a28a2.tar.gz
gnu: ghc-http-client: Update to 0.5.13.1.
* gnu/packages/haskell-web.scm (ghc-http-client): Update to 0.5.13.1.
[inputs]: Sort; add ghc-memory.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-web.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 32a7d29aec..e5ac001fad 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -181,7 +181,7 @@ responses coming back.")
 (define-public ghc-http-client
   (package
     (name "ghc-http-client")
-    (version "0.5.7.1")
+    (version "0.5.13.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://hackage.haskell.org/package/"
@@ -189,27 +189,28 @@ responses coming back.")
                                   version ".tar.gz"))
               (sha256
                (base32
-                "19cvnnfcjj2m3pgs6ivyjs21rw9wx5ynarh6hvb27a76cscai2fy"))))
+                "0szwbgvkkdz56lgi91armkagmb7nnfwbpp4j7cm9zhmffv3ba8g1"))))
     (build-system haskell-build-system)
     ;; Tests require access to the web.
     (arguments `(#:tests? #f))
     (inputs
-     `(("ghc-text" ,ghc-text)
-       ("ghc-http-types" ,ghc-http-types)
+     `(("ghc-async" ,ghc-async)
+       ("ghc-base64-bytestring" ,ghc-base64-bytestring)
        ("ghc-blaze-builder" ,ghc-blaze-builder)
-       ("ghc-data-default-class" ,ghc-data-default-class)
-       ("ghc-network" ,ghc-network)
-       ("ghc-streaming-commons" ,ghc-streaming-commons)
        ("ghc-case-insensitive" ,ghc-case-insensitive)
-       ("ghc-base64-bytestring" ,ghc-base64-bytestring)
        ("ghc-cookie" ,ghc-cookie)
+       ("ghc-data-default-class" ,ghc-data-default-class)
        ("ghc-exceptions" ,ghc-exceptions)
-       ("ghc-random" ,ghc-random)
+       ("ghc-http-types" ,ghc-http-types)
+       ("ghc-memory" ,ghc-memory)
        ("ghc-mime-types" ,ghc-mime-types)
-       ("ghc-network-uri" ,ghc-network-uri)
        ("ghc-monad-control" ,ghc-monad-control)
-       ("ghc-zlib" ,ghc-zlib)
-       ("ghc-async" ,ghc-async)))
+       ("ghc-network" ,ghc-network)
+       ("ghc-network-uri" ,ghc-network-uri)
+       ("ghc-random" ,ghc-random)
+       ("ghc-streaming-commons" ,ghc-streaming-commons)
+       ("ghc-text" ,ghc-text)
+       ("ghc-zlib" ,ghc-zlib)))
     (native-inputs
      `(("ghc-hspec" ,ghc-hspec)))
     (home-page "https://github.com/snoyberg/http-client")