summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-01-21 22:37:06 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-22 13:13:35 +0100
commit8a296947a6bdd173faeb5d7defba7069b537ddd4 (patch)
tree3c9b6b92950ae2de523b9ec48b430840cd9f8721 /gnu
parentb848f98e04e6403add7e7f6a61c2860001f1bbc3 (diff)
downloadguix-8a296947a6bdd173faeb5d7defba7069b537ddd4.tar.gz
gnu: sed: Use the same phases whether or not we're cross-compiling.
* gnu/packages/base.scm (sed)[arguments]: Make #:phases argument
unconditional.  In 'patch-test-suite' phase, use (which "sh") instead of
referring to the "bash" input.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm25
1 files changed, 11 insertions, 14 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 4898b181e9..dc6ce4f3d4 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
 ;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
@@ -129,19 +129,16 @@ including, for example, recursive directory searching.")
    (build-system gnu-build-system)
    (synopsis "Stream editor")
    (arguments
-    (if (%current-target-system)
-        '()
-        `(#:phases
-          (modify-phases %standard-phases
-            (add-before 'patch-source-shebangs 'patch-test-suite
-              (lambda* (#:key inputs #:allow-other-keys)
-                (let ((bash (assoc-ref inputs "bash")))
-                  (patch-makefile-SHELL "testsuite/Makefile.tests")
-                  (substitute* '("testsuite/bsd.sh"
-                                 "testsuite/bug-regex9.c")
-                    (("/bin/sh")
-                     (string-append bash "/bin/sh")))
-                  #t)))))))
+    `(#:phases
+      (modify-phases %standard-phases
+        (add-before 'patch-source-shebangs 'patch-test-suite
+          (lambda* (#:key inputs #:allow-other-keys)
+            (patch-makefile-SHELL "testsuite/Makefile.tests")
+            (substitute* '("testsuite/bsd.sh"
+                           "testsuite/bug-regex9.c")
+              (("/bin/sh")
+               (which "sh")))
+            #t)))))
    (native-inputs
     `(("perl" ,perl))) ; for build-aux/help2man
    (description