summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-10-30 11:10:07 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-10-30 11:15:40 +0200
commita6f2afeee185ee28157649cccc1b06ff37fe93df (patch)
treef975c807142dc9f3b56a31ae14ca99c5b86f7330 /gnu
parent24fc8f055df2138eaea74589c7f04793812f7bd8 (diff)
downloadguix-a6f2afeee185ee28157649cccc1b06ff37fe93df.tar.gz
gnu: zathura-pdf-mupdf: Simplify arguments.
* gnu/packages/pdf.scm (zathura-pdf-mupdf)[arguments]: Remove custom
'patch-plugin-directory phase, replacd with configure-flag.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/pdf.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 4c3e983497..1d37de70d7 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -435,17 +435,9 @@ using the DjVuLibre library.")
     (build-system meson-build-system)
     (arguments
      `(#:tests? #f                      ; package does not contain tests
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-plugin-directory
-           ;; Something of a regression in 0.3.3: the new Meson build system
-           ;; now hard-codes an incorrect plugin directory.  Fix it.
-           (lambda* (#:key outputs #:allow-other-keys)
-             (substitute* "meson.build"
-               (("(install_dir:).*" _ key)
-                (string-append key
-                               "'" (assoc-ref outputs "out") "/lib/zathura'\n")))
-             #t)))))
+       #:configure-flags (list (string-append "-Dplugindir="
+                                              (assoc-ref %outputs "out")
+                                              "/lib/zathura"))))
     (home-page "https://pwmt.org/projects/zathura-pdf-mupdf/")
     (synopsis "PDF support for zathura (mupdf backend)")
     (description "The zathura-pdf-mupdf plugin adds PDF support to zathura