summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-07-13 15:57:48 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-07-26 15:54:52 +0200
commita9446dde2b4113dc88101ffef1dbfff1e12e7ce6 (patch)
tree99322f77be1db94638b45d5ec0d853774d67d2a2 /gnu
parentd38755cb91952b574c1a72b7ea0ae8b52bc4f6e3 (diff)
downloadguix-a9446dde2b4113dc88101ffef1dbfff1e12e7ce6.tar.gz
gnu: make-u-boot-package: Don't install "sunxi-spl-with-ecc.bin".
* gnu/packages/bootloaders.scm (make-u-boot-package)[arguments]<#:phases>
[install]: Don't install "sunxi-spl-with-ecc.bin".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bootloaders.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 792fc4ae2f..de85ead174 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -508,7 +508,18 @@ board-independent tools.")))
                (let* ((out (assoc-ref outputs "out"))
                       (libexec (string-append out "/libexec"))
                       (uboot-files (append
-                                    (find-files "." ".*\\.(bin|efi|img|spl|itb|dtb|rksd)$")
+                                    (remove
+                                     ;; Those would not be reproducible
+                                     ;; because of the randomness used
+                                     ;; to produce them.
+                                     ;; It's expected that the user will
+                                     ;; use u-boot-tools to generate them
+                                     ;; instead.
+                                     (lambda (name)
+                                       (string-suffix?
+                                        "sunxi-spl-with-ecc.bin"
+                                        name))
+                                     (find-files "." ".*\\.(bin|efi|img|spl|itb|dtb|rksd)$"))
                                     (find-files "." "^(MLO|SPL)$"))))
                  (mkdir-p libexec)
                  (install-file ".config" libexec)