summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 18:58:18 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:10 +0300
commitbe3cf803da25efcc6a943e6a4a693bcd6dced2eb (patch)
treeee1faa3942b395a744001cd9f5283dc442b86071 /gnu
parentb12fb29e4d29d6d973618da1fa2258f127a21b5a (diff)
downloadguix-be3cf803da25efcc6a943e6a4a693bcd6dced2eb.tar.gz
gnu: Add emacs-itail.
* gnu/packages/emacs.scm (emacs-itail): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index f948becc2c..77f003c20e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8587,3 +8587,29 @@ timestamps and date-time format strings library for Emacs.")
     (description "Sequence-manipulation functions that complement basic
 functions provided by @file{subr.el}.")
     (license license:gpl3+)))
+
+(define-public emacs-itail
+  (let ((commit "6e43c20da03be3b9c6ece93b7dc3495975ec1888")
+        (revision "1"))
+    (package
+      (name "emacs-itail")
+      (version (string-append "0.0.1" "-" revision "."
+                              (string-take commit 7)))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/re5et/itail.git")
+               (commit commit)))
+         (file-name (string-append name "-" version "-checkout"))
+         (sha256
+          (base32
+           "044nzxh1hq41faxw3lix0wy78vfz304pjcaa5a11dqfz7q3gx5cv"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/re5et/itail")
+      (synopsis "Interactive @code{tail} Emacs mode")
+      (description "@code{itail} provides interactive @code{tail} mode
+that allows you to filter the tail with unix pipes and highlight the
+contents of the tailed file.  Works locally or on remote files using
+tramp.")
+      (license license:gpl3+))))