summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:11:36 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:17 +0300
commitd3f7e5333b607060b9f1abbc85134bcdfbc76a4c (patch)
tree288e92bc9161a57901627d39ee192fcbcbc2b35c /gnu
parent8f052df26c478ced54643756f47878f2b2bee094 (diff)
downloadguix-d3f7e5333b607060b9f1abbc85134bcdfbc76a4c.tar.gz
gnu: Add emacs-helm-firefox.
* gnu/packages/emacs.scm (emacs-helm-firefox): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 909943fb14..47a29a45ac 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -9812,3 +9812,26 @@ perform regression test for packages that provide font-lock rules.")
 compilation/grep buffers.  Works with @code{wgrep}, @code{ack}, @code{ag},
 @code{ivy}.")
       (license license:gpl3+))))
+
+(define-public emacs-helm-firefox
+  (let ((commit "0ad34b7b5abc485a86cae6920c14de861cbeb085")
+        (revision "1"))
+    (package
+      (name "emacs-helm-firefox")
+      (version (string-append "0.0.1" "-" revision "."
+                              (string-take commit 7)))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/emacs-helm/helm-firefox.git")
+               (commit commit)))
+         (file-name (string-append name "-" version "-checkout"))
+         (sha256
+          (base32
+           "08mjsi2f9s29fkk35cj1rrparjnkm836qmbfdwdz7y51f9varjbs"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/emacs-helm/helm-firefox")
+      (synopsis "Display firefox bookmarks with Emacs Helm interface")
+      (description "Display firefox bookmarks with Emacs Helm interface")
+      (license license:gpl3+))))