summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-27 15:44:00 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-27 16:17:19 +0100
commit1c59ec707e3a6f4496af411d4e2f46fbd4628ce4 (patch)
tree54e32997a08cc32c71d9f22f7e2c711baa62c3ba /gnu
parent585d5ae0fb7f8092d1d07f765108574001d1a3b2 (diff)
downloadguix-1c59ec707e3a6f4496af411d4e2f46fbd4628ce4.tar.gz
gnu: Add r-farver.
* gnu/packages/cran.scm (r-farver): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5f1dd03983..c943efe507 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -13120,3 +13120,28 @@ package.  The result looks like the original @code{graphics}-based plot, but
 consists of @code{grid} grobs and viewports that can then be manipulated with
 @code{grid} functions (e.g., edit grobs and revisit viewports).")
     (license license:gpl2+)))
+
+(define-public r-farver
+  (package
+    (name "r-farver")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "farver" version))
+       (sha256
+        (base32
+         "1dllgx121al374gyp9pjv1m8ip4imm8zhbgyh1970dsz2c4z71i0"))))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-rcpp" ,r-rcpp)))
+    (home-page "https://github.com/thomasp85/farver")
+    (synopsis "Vectorized color conversion and comparison")
+    (description
+     "The encoding of color can be handled in many different ways, using
+different color spaces.  As different color spaces have different uses,
+efficient conversion between these representations are important.  This
+package provides a set of functions that gives access to very fast color space
+conversion and comparisons implemented in C++, and offers 100-fold speed
+improvements over the @code{convertColor} function in the @code{grDevices}
+package.")
+    (license license:expat)))