summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-04-28 10:18:22 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-04-28 17:01:01 +0200
commit310d218f64f2521a3285311ade7c30a3066450f4 (patch)
treeedbf9e5afe747b90f8bfe1016d8dbeb040ad3ef6 /gnu
parented377cc6cfb2cf3eb45c68a7939874fbad6eac59 (diff)
downloadguix-310d218f64f2521a3285311ade7c30a3066450f4.tar.gz
gnu: Add python-tornado.
* gnu/packages/python.scm (python-tornado, python2-tornado): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 91ed9ce0df..29b47f357c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3536,6 +3536,41 @@ It is written entirely in Python.")
 (define-public python2-singledispatch
   (package-with-python2 python-singledispatch))
 
+(define-public python-tornado
+  (package
+    (name "python-tornado")
+    (version "4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/t/tornado/"
+             "tornado-" version ".tar.gz"))
+       (sha256
+        (base32 "0a12f00h277zbifibnj46wf14801f573irvf6hwkgja5vspd7awr"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-certifi" ,python-certifi)))
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (home-page "https://pypi.python.org/pypi/tornado/4.1")
+    (synopsis "Python web framework and asynchronous networking library")
+    (description
+     "Tornado is a Python web framework and asynchronous networking library,
+originally developed at FriendFeed.  By using non-blocking network I/O,
+Tornado can scale to tens of thousands of open connections, making it ideal
+for long polling, WebSockets, and other applications that require a long-lived
+connection to each user.")
+    (license asl2.0)))
+
+(define-public python2-tornado
+  (let ((tornado (package-with-python2 python-tornado)))
+    (package (inherit tornado)
+      (inputs
+       `(("python2-backport-ssl-match-hostname"
+          ,python2-backport-ssl-match-hostname)
+         ,@(package-inputs tornado))))))
+
 (define-public python-waf
   (package
     (name "python-waf")