summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 20:22:32 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:54 -0400
commit478ebb31a96955fc03fcea55a4432976ddb49319 (patch)
tree54538dcbec3d5db2cea71683bcbacbb3ddd48ed8 /gnu
parenta3d98dd8d93a1d7bdb43437b52bfca736e8e3f5c (diff)
downloadguix-478ebb31a96955fc03fcea55a4432976ddb49319.tar.gz
gnu: Add go-github-com-templexxx-reedsolomon.
* gnu/packages/syncthing.scm (go-github-com-templexxx-reedsolomon): New
variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/syncthing.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index b728c8f28b..403ffb660b 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1471,6 +1471,30 @@ using sh's word-splitting rules.")
       (home-page "https://github.com/kballard/go-shellquote")
       (license expat))))
 
+(define-public go-github-com-templexxx-reedsolomon
+  (package
+    (name "go-github-com-templexxx-reedsolomon")
+    (version "0.1.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/templexxx/reedsolomon.git")
+                     (commit version)))
+              (sha256
+               (base32
+                "05yfi6dq2mwaw6jf9vq2qhpw8vb9y94b3zi6mpfcpma262rxdkg4"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/templexxx/reedsolomon"))
+    (propagated-inputs
+     `(("go-github-com-templexxx-cpufeat"
+        ,go-github-com-templexxx-cpufeat)))
+    (synopsis "Reed-Solomon Erasure Coding in Go")
+    (description "This package provides and implemenation of Reed-Solomon
+Erasure Coding in Go.")
+    (home-page "https://github.com/templexxx/reedsolomon")
+    (license expat)))
+
 (define-public go-github-com-templexxx-cpufeat
   (let ((commit "3794dfbfb04749f896b521032f69383f24c3687e")
         (revision "0"))