summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-04-13 00:56:32 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-14 17:42:08 +0200
commit83b6da9bc4e70788d0b5e4075193060cddc42732 (patch)
tree5af9000860c4ebbbdb9cd88d427c756719bc8e65 /gnu
parent5b947258c82592ac51aeb8a1b5397badf9761585 (diff)
downloadguix-83b6da9bc4e70788d0b5e4075193060cddc42732.tar.gz
gnu: Add emacs-vimrc-mode.
* gnu/packages/emacs-xyz.scm (emacs-vimrc-mode): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c7e4091adb..8a03a46768 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14344,6 +14344,30 @@ the @code{undo} history.")
 unescaping of quotes.")
       (license license:gpl3+))))
 
+(define-public emacs-vimrc-mode
+  (let ((commit "13bc150a870d5d4a95f1111e4740e2b22813c30e")
+        (version "0.3.1")
+        (revision "1"))
+    (package
+      (name "emacs-vimrc-mode")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/mcandre/vimrc-mode")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0026dqs3hwygk2k2xfra90w5sfnxrfj7l69jz7sq5glavbf340pk"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/mcandre/vimrc-mode")
+      (synopsis "Major mode for Vimscript")
+      (description "This package provides font lock and @code{beginning-} and
+@code{end-of-defun} functions for Vimscript files.")
+      (license license:gpl3+))))
+
 (define-public emacs-semantic-refactor
   ;; The last release, 0.5, was made on 2015-07-26 and there have been 47
   ;; commits since then.