summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 20:17:47 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:53 -0400
commit936e02b4802c9a2df0031b12870d0c24f4c16844 (patch)
tree93390312ebd200176ce044b56363476b11acbc52 /gnu
parent66500b27e50acc411fd4485944e371e13eddcbaf (diff)
downloadguix-936e02b4802c9a2df0031b12870d0c24f4c16844.tar.gz
gnu: Add go-github-com-pkg-errors.
* gnu/packages/syncthing.scm (go-github-com-pkg-errors): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/syncthing.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 922c07fe74..acfa1e0c9a 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1319,6 +1319,30 @@ rolling hash.")
       (home-page "https://github.com/templexxx/xor")
       (license expat))))
 
+(define-public go-github-com-pkg-errors
+  (let ((commit "ff09b135c25aae272398c51a07235b90a75aa4f0")
+        (revision "0"))
+    (package
+      (name "go-github-com-pkg-errors")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/pkg/errors.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0pwl6v3hmc22zp32gkyqykl4kg69xk1mlp0vmhgd1f44difd5fvz"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/pkg/errors"))
+      (synopsis "Go error handling primitives")
+      (description "This packages provides @code{error}, which offers simple
+error handling primitives in Go.")
+      (home-page "https://github.com/pkg/errors")
+      (license bsd-2))))
+
 (define-public go-github-com-petermattis-goid
   (let ((commit "3db12ebb2a599ba4a96bea1c17b61c2f78a40e02")
         (revision "0"))