summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-11-18 18:54:09 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-02-10 19:03:44 +0100
commita87ea1adcb86045abd25cec712a6a24223500a14 (patch)
tree5108a35f7cff8cefa3cb9dd31ab493c92ac1a183 /gnu
parentd0c62afa8cad5e4e63b9746b4bea18922f1595bd (diff)
downloadguix-a87ea1adcb86045abd25cec712a6a24223500a14.tar.gz
gnu: Add java-jansi.
* gnu/packages/java.scm (java-jansi): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 1d4e18b72e..650abec673 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -7966,3 +7966,35 @@ that is part of the SWT Tools project.")
     (description "Java-jansi-native contains the native library for the jansi
 frobnication library/framework.")
     (license license:asl2.0)))
+
+(define-public java-jansi
+  (package
+    (name "java-jansi")
+    (version "1.16")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/fusesource/jansi/archive/"
+                                  "jansi-project-" version ".tar.gz"))
+              (sha256
+               (base32
+                "11kh3144i3fzp21dpy8zg52mjmsr214k7km9p8ly0rqk2px0qq2z"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:jar-name "jansi.jar"
+       #:source-dir "jansi/src/main/java"
+       #:test-dir "jansi/src/test"
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'check 'clear-term
+           (lambda _
+             (zero? (system* "echo" "-e" "\\e[0m")))))))
+    (inputs
+     `(("java-jansi-native" ,java-jansi-native)))
+    (native-inputs
+     `(("java-junit" ,java-junit)
+       ("java-hamcrest-core" ,java-hamcrest-core)))
+    (home-page "https://fusesource.github.io/jansi/")
+    (synopsis "Portable ANSI escape sequences")
+    (description "Jansi is a Java library that allows you to use ANSI escape
+sequences to format your console output which works on every platform.")
+    (license license:asl2.0)))