summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-30 11:39:41 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:17 +0200
commit0f9e74e9f7bef9157c7869cd9cb6ed50a8364e2d (patch)
tree9b252887c0891e4c3f65b55f8f5980dde5ccd89f /gnu
parent74f490ec0b1fab0d5df54a5b5b79b9f511197aa5 (diff)
downloadguix-0f9e74e9f7bef9157c7869cd9cb6ed50a8364e2d.tar.gz
gnu: ghc-attoparsec: Enable tests and allow newer QuickCheck.
* gnu/packages/haskell.scm (ghc-attoparsec)[arguments]: Enable tests and
add a phase that patches the Cabal file to allow a newer QuickCheck and
removes a failing test.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm17
1 files changed, 13 insertions, 4 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 7c5fef6c9b..5c1bb6f309 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2909,10 +2909,19 @@ with slicing and Clang-style colored diagnostics.")
         (base32
          "0j6qcwd146yzlkc9mcvzvnixsyl65n2a68l28322q5v9p4g4g4yx"))))
     (build-system haskell-build-system)
-    ;; FIXME: at least on test fails with QuickCheck > 2.9.2.  Once upstream
-    ;; has updated the tests to work with a later version of QuickCheck we can
-    ;; re-enable them.
-    (arguments `(#:tests? #f))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-for-newer-quickcheck
+           (lambda _
+             (substitute* "attoparsec.cabal"
+               (("QuickCheck >= 2\\.7 && < 2\\.10")
+                "QuickCheck >= 2.7 && < 2.12"))
+             ;; This test fails because of the newer QuickCheck:
+             ;; <https://github.com/bos/attoparsec/issues/134>.
+             (substitute* "tests/QC/ByteString.hs"
+               ((", testProperty \"satisfyWith\" satisfyWith")
+                "")))))))
     (inputs
      `(("ghc-scientific" ,ghc-scientific)
        ("ghc-text" ,ghc-text)))