summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-11-01 17:54:49 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2018-02-18 19:21:41 +0100
commit102fc5bc29ddf30a029c1307163fe6f8ddf0e6fb (patch)
tree9fb24e408cd56e9d879e4c08643532a26e861704 /gnu
parentac5f3988c4e6082e7c1be0a7fe9664820db33790 (diff)
downloadguix-102fc5bc29ddf30a029c1307163fe6f8ddf0e6fb.tar.gz
gnu: Add qqc2-desktop-style.
* gnu/packages/kde-frameworks.scm (qqc2-desktop-style): New
  variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 2583c8530c..4a577d5dd9 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1292,6 +1292,39 @@ which are used in DBus communication.")
 provides uniform access to generation of barcodes with data.")
     (license license:lgpl2.1+)))
 
+(define-public qqc2-desktop-style
+  (package
+    (name "qqc2-desktop-style")
+    (version "5.42.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://kde/stable/frameworks/"
+                    (version-major+minor version) "/"
+                    name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1arlfhcshfs11pgf87jzjgln1p711zlx0v0q014740mbzb9g5wnk"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("kauth" ,kauth)
+       ("kconfigwidgets" ,kconfigwidgets) ; optional
+       ("kcoreaddons" ,kcoreaddons)
+       ("kiconthemes" ,kiconthemes) ; optional
+       ("kirigami" ,kirigami)
+       ("qtbase" ,qtbase)
+       ("qtdeclarative" ,qtdeclarative)))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "QtQuickControls2 style that integrates with the desktop")
+    (description "This is a style for QtQuickControls2 which is using
+QWidget's QStyle to paint the controls in order to give it a native look and
+feel.")
+    ;; Mostly LGPL 2+, but many files are dual-licensed
+    (license (list license:lgpl2.1+ license:gpl3+))))
+
 (define-public solid
   (package
     (name "solid")