summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-09-03 21:19:12 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:13 +0200
commit5e4058ad85416bc256bc414df4985bbfd4e5eeac (patch)
treefa0e5aa1d1098c5584cda432e6a51591ecaed8f4 /gnu
parentd09b2ad42801e974eb433593891b51f9894147d9 (diff)
downloadguix-5e4058ad85416bc256bc414df4985bbfd4e5eeac.tar.gz
gnu: ghc-bytestring-handle: Allow newer base and QuickCheck.
* gnu/packages/haskell.scm (ghc-bytestring-handle)[arguments]: Add a phase
that patches the Cabal file to allow newer versions of base and QuickCheck.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 1b66d88faa..d8cd4cbba5 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7008,6 +7008,16 @@ this problem.")
         (base32
          "18f17aja1ivhr3zyg2cccn2m03hdn5jf5410dndkhf12gvgiqs7y"))))
     (build-system haskell-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'update-constraints
+           (lambda _
+             (substitute* "bytestring-handle.cabal"
+               (("QuickCheck >= 2\\.1\\.2 && < 2\\.11")
+                "QuickCheck >= 2.1.2 && < 2.12")
+               (("base >= 4\\.2 && < 4\\.11")
+                "base >= 4.2 && < 4.12")))))))
     (inputs
      `(("ghc-hunit" ,ghc-hunit)
        ("ghc-quickcheck" ,ghc-quickcheck)