summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-07-16 11:22:20 -0400
committerLeo Famulari <leo@famulari.name>2019-07-29 14:57:02 -0400
commit8201afdf0cbbba25fb09089c872211178a85fc9d (patch)
tree35dc20d2cf8166044c446846841fbdc8c50163d9 /gnu
parenta3b1dc49bb4ab68fce3af1c937545a707ae2d93b (diff)
downloadguix-8201afdf0cbbba25fb09089c872211178a85fc9d.tar.gz
gnu: Add go-github-com-cheekybits-genny.
* gnu/packages/golang.scm (go-github-com-cheekybits-genny): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 302c413880..45a77c51cc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3532,3 +3532,27 @@ mutex, simply ignore the RLock/RUnlock functions.")
 the Go standard library's TLS 1.3 implementation.")
     (home-page "https://github.com/marten-seemann/qtls")
     (license license:bsd-3)))
+
+(define-public go-github-com-cheekybits-genny
+  (package
+    (name "go-github-com-cheekybits-genny")
+    (version "1.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/cheekybits/genny")
+                     (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1pcir5ic86713aqa51581rfb67rgc3m0c72ddjfcp3yakv9vyq87"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/cheekybits/genny"))
+    (propagated-inputs
+     `(("go-golang-org-x-tools" ,go-golang-org-x-tools)))
+    (synopsis "Generics for Go")
+    (description "This package provides @code{genny}, a Go language
+implementation of generics.")
+    (home-page "https://github.com/cheekybits/genny/")
+    (license license:expat)))