summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-19 08:29:06 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-19 08:41:51 +0100
commitbaab9eef27994575e3ce1ba7efb822725600f748 (patch)
tree2c5505c56976c450da10f241c1b3686f89327252 /gnu
parente7a90f28cb2a9c662fa7213b4fefb1196acbbefd (diff)
downloadguix-baab9eef27994575e3ce1ba7efb822725600f748.tar.gz
gnu: python2-cython: Exclude parallel tests on i686 systems.
* gnu/packages/python-xyz.scm (python2-cython)[arguments]: When building on
i686-linux, override the 'check' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 86e87ae4dc..07199aa7ca 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3685,6 +3685,18 @@ writing C extensions for Python as easy as Python itself.")
        (substitute-keyword-arguments (package-arguments base)
          ((#:phases phases)
           `(modify-phases ,phases
+             ;; XXX: On i686-linux, running the parallel tests fails on many-core
+             ;; systems, see <https://github.com/cython/cython/issues/2807>.
+             ;; TODO: Move this logic to the regular check phase in a future
+             ;; rebuild cycle.
+             ,@(if (string-prefix? "i686" (%current-system))
+                   '((replace 'check
+                       (lambda _
+                         (setenv "CFLAGS" "-O0")
+                         (invoke "python" "runtests.py" "-vv"
+                                 "-j" (number->string (parallel-job-count))
+                                 "-x" "run.parallel"))))
+                   '())
              (add-before 'check 'adjust-test_embed
                (lambda _
                  (substitute* "runtests.py"