summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-09-05 15:54:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-10 16:50:26 +0200
commit3d352cb9cf2d6ddd63e345a1eb2df7e3624d66a2 (patch)
tree5d075f4fe285ee60db2cd2080594872d7e864db4 /gnu
parent098cb1e9c4548ccd78405141b32b6ec6d556c4b6 (diff)
downloadguix-3d352cb9cf2d6ddd63e345a1eb2df7e3624d66a2.tar.gz
gnu: Add python-sortedcontainers.
* gnu/packages/python.scm (python-sortedcontainers): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b6665ce3b5..b87c4787db 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14116,3 +14116,24 @@ functions, and dictionaries.")
 main differences are that @code{cytoolz} is faster and cytoolz offers a C API
 that is accessible to other projects developed in Cython.")
     (license license:bsd-3)))
+
+(define-public python-sortedcontainers
+  (package
+    (name "python-sortedcontainers")
+    (version "2.0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "sortedcontainers" version))
+       (sha256
+        (base32
+         "10hrk2k0hbf9x78vd3f0lj277m1yzfhzzxr0hja718liwb398wk0"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-tox" ,python-tox)))
+    (home-page "http://www.grantjenks.com/docs/sortedcontainers/")
+    (synopsis "Sorted List, Sorted Dict, Sorted Set")
+    (description
+     "This package provides a sorted collections library, written in
+pure-Python.")
+    (license license:asl2.0)))