summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-01-09 02:27:06 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-01-09 02:40:25 +0300
commit9a1bfd68a95fa91d3c80c2b77e0d69540cd2e8a9 (patch)
tree42e5b91a31f0d60527c9cb7a0a610e5ff89282d7 /gnu
parent60a366ec7aa777d61cd349fad5f9f32cbdb642dc (diff)
downloadguix-9a1bfd68a95fa91d3c80c2b77e0d69540cd2e8a9.tar.gz
gnu: emacs-treemacs: Refactor "install-data" phase.
* gnu/packages/emacs-xyz.scm (emacs-treemacs)[arguments]: Refactor
"install-data" phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ee0aafc50f..6c9d493c62 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17847,13 +17847,13 @@ processes for Emacs")
              #t))
          (add-after 'install 'install-data
            (lambda* (#:key outputs #:allow-other-keys)
-             (let ((images (string-append (assoc-ref outputs "out")
-                                          "/share/" ,name "/images")))
+             (let ((out (assoc-ref outputs "out")))
                (with-directory-excursion "../.." ;treemacs root
-                 (copy-recursively "icons/default" images)
-                 (copy-recursively "src/scripts"
-                                   (string-append (assoc-ref outputs "out")
-                                                  "/share/" ,name "/scripts"))
+                 (copy-recursively "icons/default"
+                  (string-append out "/share/" ,name "/images"))
+                 (copy-recursively
+                  "src/scripts"
+                  (string-append out "/share/" ,name "/scripts"))
                  #t)))))))
     (home-page "https://github.com/Alexander-Miller/treemacs")
     (synopsis "Emacs tree style file explorer")