summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-07-23 15:23:27 -0300
committerMarius Bakke <marius@gnu.org>2020-07-25 18:47:56 +0200
commit04a3cb9984a81bbac2dc1f2ac8d00fc12cd4b96d (patch)
treec6e1bfa06ad7fecccd50026e80c069992d41f2d6 /gnu
parent8974f7d0653a3f7e7ba0a1884d60da2442cf5eca (diff)
downloadguix-04a3cb9984a81bbac2dc1f2ac8d00fc12cd4b96d.tar.gz
gnu: Add python-pytest-remotedata.
* gnu/packages/python-check.scm (python-pytest-remotedata): New variable.

Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-check.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 5140057f91..506b95556c 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -247,6 +247,41 @@ developers to detect whether any file handles or other file-like objects
 were inadvertently left open at the end of a unit test.")
     (license license:bsd-3)))
 
+(define-public python-pytest-remotedata
+  (package
+    (name "python-pytest-remotedata")
+    (version "0.3.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-remotedata" version))
+       (sha256
+        (base32 "1h6g6shib6z07azf12rnsa053470ggbd7hy3bnbw8nf3nza5h372"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             ;; Make the installed plugin discoverable by Pytest.
+             (add-installed-pythonpath inputs outputs)
+             (invoke "pytest" "-vv" "-k"
+                     (string-append
+                      ;; These tests require internet access. Disable them.
+                      "not test_default_behavior"
+                      " and not test_strict_with_decorator")))))))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)))
+    (propagated-inputs
+     `(("python-six" ,python-six)))
+    (home-page "https://github.com/astropy/pytest-remotedata")
+    (synopsis "Pytest plugin for controlling remote data access")
+    (description
+     "This package provides a plugin for the Pytest framework that allows
+developers to control unit tests that require access to data from the
+internet.")
+    (license license:bsd-3)))
+
 (define-public python-pytest-vcr
   ;; This commit fixes integration with pytest-5
   (let ((commit "4d6c7b3e379a6a7cba0b8f9d20b704dc976e9f05")