summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-11-08 17:01:59 -0500
committerKei Kebreau <kkebreau@posteo.net>2018-11-18 11:58:38 -0500
commit1472d19abf49352c404c285546526457898de113 (patch)
tree556f35336974117dae972d67c22796fbd3342b5c /gnu
parentd22ba64276c0bbacb77d0670635f67f053a16c6b (diff)
downloadguix-1472d19abf49352c404c285546526457898de113.tar.gz
gnu: maxima: Fix tests on i686 and x86_64.
* gnu/packages/maths.scm (maxima)[arguments]: Replace check phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index b1cddfd80a..05570789a0 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2788,6 +2788,18 @@ to BMP, JPEG or PNG image formats.")
            (lambda _
              (chmod "src/maxima" #o555)
              #t))
+         (replace 'check
+           (lambda _
+             ;; This is derived from the testing code in the "debian/rules" file
+             ;; of Debian's Maxima package.
+             ;; If Maxima can successfully run this, the binary to be installed
+             ;; should be fine.
+             (zero?
+              (system
+               (string-append "./maxima-local "
+                              "--lisp=gcl "
+                              "--batch-string=\"run_testsuite();\" "
+                              "| grep -q \"No unexpected errors found\"")))))
          ;; Make sure the doc and emacs files are found in the
          ;; standard location.  Also configure maxima to find gnuplot
          ;; without having it on the PATH.