summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-10 21:03:28 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-11 01:13:23 +0100
commit1debba19db18cafa189ada576f65b4d78933add7 (patch)
tree8f3c1d944dfb096ce20fdc8b23348c55f759974a /gnu
parent9ae87870bf670c1eb7312f883260f6b0d417338a (diff)
downloadguix-1debba19db18cafa189ada576f65b4d78933add7.tar.gz
gnu: frei0r-plugins: Update to 1.7.0.
* gnu/packages/video.scm (frei0r-plugins): Update to 1.7.0.
[native-inputs]: Remove LIBTOOL, AUTOCONF and AUTOMAKE.
[arguments]: Remove 'autotools' phase.  Add 'patch-Makefile' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index f337d5f6c6..289cc29917 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3216,7 +3216,7 @@ alpha blending etc).")
 (define-public frei0r-plugins
   (package
     (name "frei0r-plugins")
-    (version "1.6.1")
+    (version "1.7.0")
     (source
      (origin
        (method url-fetch)
@@ -3224,23 +3224,25 @@ alpha blending etc).")
                            "frei0r-plugins-" version ".tar.gz"))
        (sha256
         (base32
-         "0pji26fpd0dqrx1akyhqi6729s394irl73dacnyxk58ijqq4dhp0"))))
+         "0fjji3060r4fwr7vn91lwfzl80lg3my9lkp94kbyw8xwz7qgh7qv"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'autotools
+         (add-after 'unpack 'patch-Makefile
            (lambda _
-             (invoke "sh" "autogen.sh"))))))
+             ;; XXX: The 1.7.0 Makefile looks for files that have slightly different
+             ;; names in the tarball.  Try removing this for future versions.
+             (substitute* "Makefile.in"
+               (("README\\.md ChangeLog TODO AUTHORS")
+                "README.txt ChangeLog.txt TODO.txt AUTHORS.txt"))
+             #t)))))
     ;; TODO: opencv for additional face detection filters.
     (inputs
      `(("gavl" ,gavl)
        ("cairo" ,cairo)))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("libtool" ,libtool)
-       ("automake" ,automake)
-       ("autoconf" ,autoconf)))
+     `(("pkg-config" ,pkg-config)))
     (home-page "https://www.dyne.org/software/frei0r/")
     (synopsis "Minimalistic plugin API for video effects")
     (description