summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-03 06:27:09 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-03 06:38:57 +0100
commit213c32e4b231b767458658bdfd673a9832a73a81 (patch)
tree2b1d10290684ce5e7036946a809bee95d99dbcd8 /gnu
parent9ae99a69c083868aa52826fe7e8e54a3b96ad3cb (diff)
downloadguix-213c32e4b231b767458658bdfd673a9832a73a81.tar.gz
gnu: colormake: Don't use unstable tarball.
* gnu/packages/code.scm (colormake)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
[native-inputs]: Remove gzip and tar.
[arguments]: Copy the source checkout instead of extracting the source
tarball.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/code.scm24
1 files changed, 9 insertions, 15 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 67a2f80a00..2b858c4719 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -461,30 +461,24 @@ importantly we give you proper follow-symbol and find-references support.")
     (version "0.9.20140503")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/pagekite/Colormake/archive/"
-                           version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/pagekite/Colormake.git")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "08ldss9zd8ls6bjahvxhffpsjcysifr720yf3jz9db2mlklzmyd3"))))
+        (base32 "1f9v5s0viq4yc9iv6701h3pv7j21zz1ckl37lpp9hsnliiizv03p"))))
     (build-system trivial-build-system)
     (native-inputs
      `(("bash" ,bash)
-       ("gzip" ,gzip)
-       ("perl" ,perl)
-       ("tar" ,tar)))
+       ("perl" ,perl)))
     (arguments
      `(#:modules ((guix build utils))
        #:builder
        (begin
          (use-modules (guix build utils))
-         ;; bootstrap
-         (setenv "PATH" (string-append
-                         (assoc-ref %build-inputs "tar") "/bin" ":"
-                         (assoc-ref %build-inputs "gzip") "/bin"))
-         (invoke "tar" "xvf" (assoc-ref %build-inputs "source"))
-         (chdir (string-append (string-capitalize ,name) "-" ,version))
+         (copy-recursively (assoc-ref %build-inputs "source") "source")
+         (chdir "source")
          (patch-shebang  "colormake.pl"
                          (list (string-append (assoc-ref %build-inputs "perl")
                                               "/bin")))