summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-06-27 15:36:31 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-07-17 04:15:47 +0200
commit8815719c96156023e1f4d10868b11c0b6b36d4f9 (patch)
tree39fc5846145c16cc3e5bcb6cc1a3d4ba1d01d99a /gnu
parenta1ed79363fb8f3187330c0a5343faa0891b3d704 (diff)
downloadguix-8815719c96156023e1f4d10868b11c0b6b36d4f9.tar.gz
gnu: Add java-sonatype-aether-util.
* gnu/packages/maven.scm (java-sonatype-aether-util): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maven.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/maven.scm b/gnu/packages/maven.scm
index 5a8e7303e3..153671c387 100644
--- a/gnu/packages/maven.scm
+++ b/gnu/packages/maven.scm
@@ -430,6 +430,26 @@ for repository system implementations and repository connectors.")))
     (description "This package contains a collection of utility classes to
 ease testing of the repository system.")))
 
+(define-public java-sonatype-aether-util
+  (package
+    (inherit java-sonatype-aether-api)
+    (name "java-sonatype-aether-util")
+    (arguments
+     `(#:jar-name "aether-util.jar"
+       #:source-dir "aether-util/src/main/java"
+       #:test-dir "aether-util/src/test"
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'install (install-from-pom "aether-util/pom.xml")))))
+    (propagated-inputs
+     `(("java-sonatype-aether-api" ,java-sonatype-aether-api)))
+    (native-inputs
+     `(("java-junit" ,java-junit)
+       ("java-sonatype-aether-test-util" ,java-sonatype-aether-test-util)))
+    (synopsis "Utility classes for the maven repository system")
+    (description "This package contains a collection of utility classes to
+ease usage of the repository system.")))
+
 (define-public maven-shared-utils
   (package
     (name "maven-shared-utils")