summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 16:44:13 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 17:13:52 +0100
commitafc0d8158b654381789b7e1c9dea9512cf63afbf (patch)
tree87b6c4fe0544ef1aec7d797b72f1ff3bec36d06c /gnu
parent4fcbd7eaf33bd597f8e982f4d230f3670bbd64cf (diff)
downloadguix-afc0d8158b654381789b7e1c9dea9512cf63afbf.tar.gz
gnu: Add r-bootstrap.
* gnu/packages/cran.scm (r-bootstrap): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f2fb042112..00eab12c92 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10055,3 +10055,26 @@ meta-analysis for two-sample comparisons and cumulative meta-analyses.  It
 draws standard summary plots, funnel plots, and computes summaries and tests
 for association and heterogeneity.")
     (license license:gpl2)))
+
+(define-public r-bootstrap
+  (package
+    (name "r-bootstrap")
+    (version "2017.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "bootstrap" version))
+       (sha256
+        (base32
+         "08lmsy7k8wsgv89yc904c6fidcymr1ma2ry4fl0p69p21v4iiwa4"))))
+    (build-system r-build-system)
+    (native-inputs `(("gfortran" ,gfortran)))
+    (home-page "https://cran.r-project.org/web/packages/bootstrap")
+    (synopsis "Functions for the book \"An Introduction to the Bootstrap\"")
+    (description
+     "This package provides software and data for the book \"An Introduction
+to the Bootstrap\" by B. Efron and R. Tibshirani, 1993, Chapman and Hall.
+This package is primarily provided for projects already based on it, and for
+support of the book.  New projects should preferentially use the recommended
+package \"boot\".")
+    (license license:bsd-3)))