summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-09-12 16:13:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-09-12 17:44:46 +0200
commitb90314b4f829fda6eb0245198151123c40736fc1 (patch)
tree89606f74c8d34c11094df37299f4f49f5b279794 /gnu
parenta589acfb08882cf7978d53a21d0ed27926b44a4e (diff)
downloadguix-b90314b4f829fda6eb0245198151123c40736fc1.tar.gz
gnu: Add r-hms.
* gnu/packages/statistics.scm (r-hms): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index d6b57b7fa7..eccc704405 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1732,6 +1732,25 @@ in which global state has been temporarily modified.  Many of these functions
 were originally a part of the r-devtools package.")
     (license license:gpl2+)))
 
+(define-public r-hms
+  (package
+    (name "r-hms")
+    (version "0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "hms" version))
+       (sha256
+        (base32
+         "0ln1dc26mkl5pc26vvyf01d35x75q6cjaj39cccxp67chbwbdlds"))))
+    (build-system r-build-system)
+    (home-page "https://github.com/rstats-db/hms")
+    (synopsis "Pretty time of day")
+    (description
+     "This package implements an S3 class for storing and formatting
+time-of-day values, based on the @code{difftime} class.")
+    (license license:gpl3+)))
+
 (define-public r-readr
   (package
     (name "r-readr")