summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorFis Trivial <ybbs.daans@hotmail.com>2018-04-27 07:03:24 +0000
committerLudovic Courtès <ludo@gnu.org>2018-04-30 14:35:17 +0200
commitfb8966abc43415ca6d1f141c44ebf0c563cea4d2 (patch)
tree6dd12f41ee1f8ad7e88aebf77673dc19f2604283 /gnu
parent8b2597d54286ccf140592ea352fd19c7323f7746 (diff)
downloadguix-fb8966abc43415ca6d1f141c44ebf0c563cea4d2.tar.gz
gnu: python-jedi: Update to 0.12.0, enable tests.
* gnu/packages/python.scm (jedi): Update to 0.12.0, enable tests.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm29
1 files changed, 17 insertions, 12 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f23deb57e6..a359eebd12 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9357,25 +9357,30 @@ characters, mouse support, and auto suggestions.")
 (define-public python-jedi
   (package
     (name "python-jedi")
-    (version "0.9.0")
+    (version "0.12.0")
     (source
-      (origin
-        (method url-fetch)
-        (uri (pypi-uri "jedi" version))
-        (sha256
-          (base32
-            "0c8x962ynpx001fdvp07m2q5jk4igkxbj3rmnydavphvlgxijk1v"))))
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "jedi" version))
+       (sha256
+        (base32
+         "1bcr7csx4xil1iwmk03d79jis0bkmgi9k0kir3xa4rmwqsagcwhr"))))
     (build-system python-build-system)
     (arguments
-     ;; FIXME: One test fails (use "py.test" instead of 'setup.py test').
-     '(#:tests? #f))
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check (lambda _
+                           (invoke "py.test" "-vv"))))))
     (native-inputs
-     `(("python-pytest" ,python-pytest)))
+     `(("python-pytest" ,python-pytest)
+       ("python-parso" ,python-parso)
+       ("python-docopt" ,python-docopt)))
     (home-page "https://github.com/davidhalter/jedi")
     (synopsis
-      "Autocompletion for Python that can be used for text editors")
+     "Autocompletion for Python that can be used for text editors")
     (description
-      "Jedi is an autocompletion tool for Python that can be used for text editors.")
+     "Jedi is an autocompletion tool for Python that can be used for text
+ editors.")
     (license license:expat)))
 
 (define-public python2-jedi