summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-09 00:13:50 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-09 00:13:50 +0100
commit60a366ec7aa777d61cd349fad5f9f32cbdb642dc (patch)
tree744084f199e795f7402ce8c244c501df9f0d709d /gnu
parent907eeac2e7d5d9c10b65038d486876e577c80d85 (diff)
downloadguix-60a366ec7aa777d61cd349fad5f9f32cbdb642dc.tar.gz
gnu: util-linux: Rename udev variant.
Some packages propagate util-linux, so make sure that that manifests and
similar choose the same version to avoid conflicts.

* gnu/packages/linux.scm (util-linux)[properties]: Remove.
(util-linux+udev)[name]: Set to "util-linux-with-udev".
[properties]: Remove.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3c720f32fc..ee571f12ad 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1182,9 +1182,6 @@ providing the system administrator with some help in common tasks.")
 utilities.  It provides dmesg and includes tools for working with file systems,
 block devices, UUIDs, TTYs, and many other tools.")
 
-    ;; Hide the package so that end users get the udev-enabled variant below.
-    (properties '((hidden? . #t)))
-
     ;; Note that util-linux doesn't use the same license for all the
     ;; code.  GPLv2+ is the default license for a code without an
     ;; explicitly defined license.
@@ -1197,10 +1194,10 @@ block devices, UUIDs, TTYs, and many other tools.")
 (define-public util-linux+udev
   (package/inherit
    util-linux
+   (name "util-linux-with-udev")
    (inputs
     `(("udev" ,eudev)
-      ,@(package-inputs util-linux)))
-   (properties (alist-delete 'hidden? (package-properties util-linux)))))
+      ,@(package-inputs util-linux)))))
 
 (define-public ddate
   (package