summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-08-03 22:22:43 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-08-04 01:51:21 +0200
commit7a068459ba9f1dd6f3dee12e39124a0c8b603ced (patch)
tree49cedd7cfd658cee945e6569e2b493503e1a2731 /gnu
parent0f08917df3f35ba5b54361c4b27255304102ced4 (diff)
downloadguix-7a068459ba9f1dd6f3dee12e39124a0c8b603ced.tar.gz
gnu: zerofree: Use ‘install-file’.
* gnu/packages/linux.scm (zerofree)[arguments]: Simplify install phase,
using ‘install-file’.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 76f97f7e8a..481037066b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -841,11 +841,8 @@ ext3 or ext4 partition.")
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
                     (bin (string-append out "/bin")))
-               (mkdir-p bin)
-               (copy-file "zerofree"
-                          (string-append bin "/zerofree"))
-               (chmod (string-append bin "/zerofree")
-                      #o555)
+               (chmod "zerofree" #o555)
+               (install-file "zerofree" bin)
                #t))))
        #:tests? #f))                    ; no tests
     (inputs `(("libext2fs" ,e2fsprogs)))