summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-12-30 00:13:53 -0500
committerLeo Famulari <leo@famulari.name>2016-01-15 16:45:24 -0500
commit89b8a5516fe3c72befc256652cfb27cb41a4f977 (patch)
treecf478b684f41fd5d44e98f3b155a153602425415 /gnu
parent28cecbb7ccbb87593d5f81b4ab0a7d32477b10f4 (diff)
downloadguix-89b8a5516fe3c72befc256652cfb27cb41a4f977.tar.gz
gnu: Add python-pytest-xprocess.
* gnu/packages/python.scm (python-pytest-xprocess): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9bc8b8dfef..7b400d11cc 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6907,3 +6907,24 @@ program.  Thus, you can avoid spawning multiple processes or threads to test
 your Web app.")
     (home-page "https://github.com/cdent/wsgi-intercept")
     (license license:expat)))
+
+(define-public python-pytest-xprocess
+  (package
+    (name "python-pytest-xprocess")
+    (version "0.9.1")
+    (source (origin
+             (method url-fetch)
+             (uri (pypi-uri "pytest-xprocess" version))
+             (sha256
+              (base32
+               "17zlql1xqw3ywcgwwbqmw633aly99lab12hm02asr8awvg5603pp"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-pytest-cache" ,python-pytest-cache)
+       ("python-psutil" ,python-psutil)))
+    (synopsis "Pytest plugin to manage external processes across test runs")
+    (description "Pytest-xprocess is an experimental py.test plugin for managing
+processes across test runs.")
+    (home-page "https://bitbucket.org/pytest-dev/pytest-xprocess")
+    (license license:expat)))