summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-06-15 04:36:19 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-06-25 08:54:37 +0200
commite7dc1a39c0535be5cc0527ac3bf4b52b0c5ed75c (patch)
treea801177345a34e83e02aacc156b69796aac037c3 /gnu
parentd6681c435c4d605edafe784748b576670bcd42b5 (diff)
downloadguix-e7dc1a39c0535be5cc0527ac3bf4b52b0c5ed75c.tar.gz
gnu: Add emacs-org-super-agenda.
* gnu/packages/emacs-xyz.scm (emacs-org-super-agenda): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3647b2d8f6..50b9a20e48 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10185,6 +10185,31 @@ a heuristic based on frequency and recency.")
 as well as functions for navigating between these headings.")
     (license license:gpl3+)))
 
+(define-public emacs-org-super-agenda
+  (package
+   (name "emacs-org-super-agenda")
+   (version "1.1")
+   (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url "https://github.com/alphapapa/org-super-agenda")
+                  (commit version)))
+            (file-name (git-file-name name version))
+            (sha256
+             (base32
+              "0vzf91lsxnhwf52kvm8ycpf0wb9c8l91689vyhwgv4wz8q6cvjwp"))))
+   (build-system emacs-build-system)
+   (propagated-inputs
+    `(("emacs-org" ,emacs-org)
+      ("emacs-dash" ,emacs-dash)
+      ("emacs-ht" ,emacs-ht)
+      ("emacs-s" ,emacs-s)))
+   (home-page "https://github.com/alphapapa/org-super-agenda")
+   (synopsis "Supercharged Org agenda")
+   (description "This package allows items in the Org agenda to be grouped
+into sections while preserving the structure imposed by any timestamps.")
+   (license license:gpl3+)))
+
 (define-public emacs-parsebib
   (package
     (name "emacs-parsebib")