summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2019-07-12 23:47:20 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2019-07-13 00:22:55 +0300
commit6cf63fe887e81821e217db9bbd27a1d6cefff013 (patch)
treea0fece805ab6ea00433afc1197e8b47ccab342d9 /gnu
parent5516a75b0b5c19f25b8fec3a647608ae44c1adf2 (diff)
downloadguix-6cf63fe887e81821e217db9bbd27a1d6cefff013.tar.gz
gnu: Add emacs-gitlab-ci-mode.
* gnu/packages/emacs-xyz.scm (emacs-gitlab-ci-mode): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fb305dda0c..4e8c2c9ac6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5829,6 +5829,31 @@ that indentation determines structure, this mode provides indentation and
 indentation command behavior very similar to that of python-mode.")
     (license license:gpl3+)))
 
+(define-public emacs-gitlab-ci-mode
+  (package
+    (name "emacs-gitlab-ci-mode")
+    (version "20190425.11.10")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.com/joewreschnig/gitlab-ci-mode.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1jkp9mnbiccqnha9zs646znqyqvy5jjb81kah7ghbkzdqqk2avm0"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-yaml-mode" ,emacs-yaml-mode)))
+    (home-page "https://gitlab.com/joewreschnig/gitlab-ci-mode/")
+    (synopsis "Emacs mode for editing GitLab CI files")
+    (description
+     "@code{gitlab-ci-mode} is an Emacs major mode for editing GitLab CI
+files.  It provides syntax highlighting and completion for keywords and
+special variables.  An interface to GitLab’s CI file linter is also provided
+via @code{gitlab-ci-lint}.")
+    (license license:gpl3+)))
+
 (define-public emacs-web-mode
   (package
     (name "emacs-web-mode")