summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-09-04 22:31:29 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-09-04 23:08:22 +0200
commit72b2e2ea7a546b09a66d36260fcc60cae70a0151 (patch)
tree92691c123133736d957b16adb6bf3eb03099e3b2 /gnu
parent8dfe8fee5408c6a4b31866d5e7c073100e3ea285 (diff)
downloadguix-72b2e2ea7a546b09a66d36260fcc60cae70a0151.tar.gz
gnu: ocaml-lwt-log: Update to 1.1.1.
* gnu/packages/ocaml.scm (ocaml-lwt-log): Update to 1.1.1.
[source]: Use git-fetch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0fef79574c..493542d48a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1870,15 +1870,16 @@ locks or other synchronization primitives.")
 (define-public ocaml-lwt-log
   (package
     (name "ocaml-lwt-log")
-    (version "1.1.0")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (string-append "https://github.com/aantron/lwt_log/archive/" version
-                            ".tar.gz"))
-        (file-name (string-append name "-" version ".tar.gz"))
-        (sha256 (base32
-                  "1lr62j2266pbsi54xmzsfvl2z7fi7smhak7fp1ybl8hssxwi6in2"))))
+    (version "1.1.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/aantron/lwt_log")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1n12i1rmn9cjn6p8yr6qn5dwbrwvym7ckr7bla04a1xnq8qlcyj7"))))
     (build-system dune-build-system)
     (arguments
      `(#:tests? #f; require lwt_ppx