summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-13 19:15:21 +0100
committerLeo Famulari <leo@famulari.name>2016-12-13 17:04:19 -0500
commitc8cd850c87f50b476dc87166e09207426efd8409 (patch)
tree046e6ad5938cc4817dc5708583d565d830c15f3b /gnu
parentcff0ccf9dce5bb0c6c504909be7dfc581f3068a9 (diff)
downloadguix-c8cd850c87f50b476dc87166e09207426efd8409.tar.gz
gnu: python-xcffib: Use 'modify-phases' syntax.
* gnu/packages/python.scm (python-xcffib)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 200ba30498..6aee72cf70 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4230,15 +4230,15 @@ a front-end for C compilers or analysis tools.")
        ("python-six" ,python-six)))
     (arguments
      `(#:phases
-       (alist-cons-after
-        'install 'install-doc
-        (lambda* (#:key outputs #:allow-other-keys)
-          (let ((doc (string-append (assoc-ref outputs "out") "/share"
-                                    "/doc/" ,name "-" ,version)))
-            (mkdir-p doc)
-            (copy-file "README.md"
-                       (string-append doc "/README.md"))))
-        %standard-phases)))
+       (modify-phases %standard-phases
+         (add-after 'install 'install-doc
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((doc (string-append (assoc-ref outputs "out") "/share"
+                                       "/doc/" ,name "-" ,version)))
+               (mkdir-p doc)
+               (copy-file "README.md"
+                          (string-append doc "/README.md"))
+               #t))))))
     (home-page "https://github.com/tych0/xcffib")
     (synopsis "XCB Python bindings")
     (description