summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-09-03 22:43:07 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-09-03 23:32:26 +0200
commite60330510a0c0b6c080a0878be6aa40644456314 (patch)
treee01aa83b9b9e15ad05e16ba1ffc544e7b4efb575 /gnu
parenta468fc5e8ce42b8e2d99b843c9646c084f7a734f (diff)
downloadguix-e60330510a0c0b6c080a0878be6aa40644456314.tar.gz
gnu: Add ocaml-charinfo-width.
* gnu/packages/ocaml.scm (ocaml-charinfo-width): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 1c938beac2..3f661b74e1 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2984,6 +2984,30 @@ library is currently designed for Unicode Standard 3.2.")
     ;; with an exception for linked libraries to use a different license
     (license license:lgpl2.0+)))
 
+(define-public ocaml-charinfo-width
+  (package
+    (name "ocaml-charinfo-width")
+    (version "1.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri "https://bitbucket.org/zandoye/charinfo_width/get/1.1.0.tar.gz")
+              (sha256
+               (base32
+                "00bv4p1yqs8y0z4z07wd9w9yyv669dikp9b04dcjbwpiy2wy0086"))))
+    (build-system dune-build-system)
+    (propagated-inputs
+     `(("ocaml-result" ,ocaml-result)
+       ("ocaml-camomile" ,ocaml-camomile)))
+    (native-inputs
+     `(("ocaml-ppx-expect" ,ocaml-ppx-expect)))
+    (properties
+     `((upstream-name . "charInfo_width")))
+    (home-page "https://bitbucket.org/zandoye/charinfo_width/")
+    (synopsis "Determine column width for a character")
+    (description "This module is implements purely in OCaml a character width
+function that follows the prototype of POSIX's wcwidth.")
+    (license license:expat)))
+
 (define-public ocaml-zed
   (package
     (name "ocaml-zed")