summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2017-05-17 15:14:32 -0400
committerLudovic Courtès <ludo@gnu.org>2017-05-18 14:22:03 +0200
commitf69c29f76d250897f70f6e189dfc2b0e4b8e4fa3 (patch)
treee307cea0238d79be62db0d9a697b80fef2e53ed6 /gnu
parent03cc1cf35b73e258f504c2dc4eeb1c8f2f599c13 (diff)
downloadguix-f69c29f76d250897f70f6e189dfc2b0e4b8e4fa3.tar.gz
gnu: Add emacs-helm-projectile.
* gnu/packages/emacs.scm (emacs-helm-projectile): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 66eaea5185..4a0d20c9f1 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3411,6 +3411,31 @@ not tied in the trap of backward compatibility.")
 for search-based navigation of buffers.")
     (license license:gpl2+)))
 
+(define-public emacs-helm-projectile
+  (package
+    (name "emacs-helm-projectile")
+    (version "0.14.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/bbatsov/helm-projectile/archive/v"
+                    version
+                    ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "19cfmilqh8kbab3b2hmx6lyrj73q6vfmn3p730x95g23iz16mnd5"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-dash" ,emacs-dash)
+       ("emacs-helm" ,emacs-helm)
+       ("emacs-projectile" ,emacs-projectile)))
+    (home-page "https://github.com/bbatsov/helm-projectile")
+    (synopsis "Helm integration for Projectile")
+    (description
+     "This Emacs library provides a Helm interface for Projectile.")
+    (license license:gpl3+)))
+
 (define-public emacs-cider
   (package
     (name "emacs-cider")