summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-04-26 22:51:07 +0200
committerLudovic Courtès <ludo@gnu.org>2013-04-26 22:51:07 +0200
commit3b401612d9ea23cf20f5377594251a82c28e03e6 (patch)
tree938062c965f087abc89135ae20b00ae3d8b7e3bc /gnu
parent6aded2dd3fdeb349f18e9085bf700ea1bb926c0b (diff)
downloadguix-3b401612d9ea23cf20f5377594251a82c28e03e6.tar.gz
gnu: Binutils 2.23.2 and GCC 4.7.3.
* gnu/packages/base.scm (binutils): Update to 2.23.2.
  (binutils-2.23, ld-wrapper-2.23): Remove.
  (gcc-4.8): Move to...
* gnu/packages/gcc.scm (gcc-4.8): ... here.
  (gcc-4.7): Update to 4.7.3.  Add dependencies on ISL, CLooG, libelf,
  and zlib.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm44
-rw-r--r--gnu/packages/gcc.scm26
2 files changed, 23 insertions, 47 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 2afb64ab9e..fae0c8151f 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -337,14 +337,14 @@ that it is possible to use Make to build and install the program.")
 (define-public binutils
   (package
    (name "binutils")
-   (version "2.23.1")
+   (version "2.23.2")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/binutils/binutils-"
                                 version ".tar.bz2"))
             (sha256
              (base32
-              "06bs5v5ndb4g5qx96d52lc818gkbskd1m0sz57314v887sqfbcia"))))
+              "15qhbkz3r266xaa52slh857qn3abw7rb2x2jnhpfrafpzrb4x4gy"))))
    (build-system gnu-build-system)
 
    ;; Split Binutils in several outputs, mostly to avoid collisions in
@@ -376,17 +376,6 @@ BFD (Binary File Descriptor) library, `gprof', `nm', `strip', etc.")
    (license gpl3+)
    (home-page "http://www.gnu.org/software/binutils/")))
 
-(define-public binutils-2.23
-  (package (inherit binutils)
-    (version "2.23.2")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append "mirror://gnu/binutils/binutils-"
-                                 version ".tar.bz2"))
-             (sha256
-              (base32
-               "15qhbkz3r266xaa52slh857qn3abw7rb2x2jnhpfrafpzrb4x4gy"))))))
-
 (define-public glibc
   (package
    (name "glibc")
@@ -962,35 +951,6 @@ store.")
               ,@(fold alist-delete (package-inputs ld-wrapper-boot3)
                       '("guile" "bash"))))))
 
-(define-public ld-wrapper-2.23         ; TODO: remove when Binutils is updated
-  (package (inherit ld-wrapper)
-    (inputs `(("binutils" ,binutils-2.23)
-              ,@(alist-delete "binutils" (package-inputs ld-wrapper))))))
-
-(define-public gcc-4.8
-  ;; FIXME: Move to gcc.scm when Binutils is updated.
-  (package (inherit gcc-4.7)
-    (version "4.8.0")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append "mirror://gnu/gcc/gcc-"
-                                 version "/gcc-" version ".tar.bz2"))
-             (sha256
-              (base32
-               "0b6cp9d1sas3vq6dj3zrgd134p9b569fqhbixb9cl7mp698zwdxh"))))
-    (inputs `(("gmp" ,gmp)
-              ("mpfr" ,mpfr)
-              ("mpc" ,mpc)
-              ("isl" ,isl)
-              ("cloog" ,cloog)
-              ("zlib" ,(@ (gnu packages compression) zlib))
-
-              ;; With ld from Binutils 2.22, we get the following error while
-              ;; linking gcov:
-              ;; ld: gcov: hidden symbol `__deregister_frame_info' in /nix/store/47myfniw4x7kfc601d7q1yvz5mixlr00-gcc-4.7.2/lib/gcc/x86_64-unknown-linux-gnu/4.7.2/libgcc_eh.a(unwind-dw2-fde-dip.o) is referenced by DSO
-              ;; See <http://gcc.gnu.org/bugzilla/show_bug.cgi?id=57015>.
-              ("ld-wrapper" ,ld-wrapper-2.23)))))
-
 (define-public %final-inputs
   ;; Final derivations used as implicit inputs by `gnu-build-system'.
   (let ((finalize (cut package-with-explicit-inputs <> %boot4-inputs
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 96b82d5af7..d239b5a9ab 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -35,18 +35,22 @@
   (let ((stripped? #t))                         ; TODO: make this a parameter
     (package
      (name "gcc")
-     (version "4.7.2")
+     (version "4.7.3")
      (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnu/gcc/gcc-"
                                   version "/gcc-" version ".tar.bz2"))
               (sha256
                (base32
-                "115h03hil99ljig8lkrq4qk426awmzh0g99wrrggxf8g07bq74la"))))
+                "1hx9h64ivarlzi4hxvq42as5m9vlr5cyzaaq4gzj4i619zmkfz1g"))))
      (build-system gnu-build-system)
-     (inputs `(("gmp" ,gmp)
-               ("mpfr" ,mpfr)
-               ("mpc" ,mpc)))           ; TODO: libelf, ppl, cloog, zlib, etc.
+    (inputs `(("gmp" ,gmp)
+              ("mpfr" ,mpfr)
+              ("mpc" ,mpc)
+              ("isl" ,isl)
+              ("cloog" ,cloog)
+              ("libelf" ,libelf)
+              ("zlib" ,zlib)))
      (arguments
       `(#:out-of-source? #t
         #:strip-binaries? ,stripped?
@@ -152,6 +156,18 @@ used in the GNU system including the GNU/Linux variant.")
      (license gpl3+)
      (home-page "http://gcc.gnu.org/"))))
 
+(define-public gcc-4.8
+  ;; FIXME: Move to gcc.scm when Binutils is updated.
+  (package (inherit gcc-4.7)
+    (version "4.8.0")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "mirror://gnu/gcc/gcc-"
+                                 version "/gcc-" version ".tar.bz2"))
+             (sha256
+              (base32
+               "0b6cp9d1sas3vq6dj3zrgd134p9b569fqhbixb9cl7mp698zwdxh"))))))
+
 (define-public isl
   (package
     (name "isl")